Application stopping after seconds, used to work.

Feb 7, 2011 at 11:18 AM
Edited Feb 7, 2011 at 11:28 AM

Hello,

I've been working on a application which uses GoblinXNA for a while, and it had done a great job for months, untill yesterday. Suddenly, code that had been in place for months stopped functioning.

I used to run it in debug mode because my dlls were somewhat messed up in the release folder, but now when I use the .exe  in the debug folder, the application starts, the webcam turns on, and then nothing, the application shuts down. When running it in debug mode in visual studio however, I got the following error:

 

LoaderLock was detected

Attempting managed execution inside OS Loader lock. Do not attempt to run managed code inside a DllMain or image initialization function since doing so can cause the application to hang.

 

This error was thrown at the line

tracker.InitTracker(captureDevice.Width, captureDevice.Height, "calib.xml", 9.0);

 

Removing LoaderLock from the exceptions that shuld be thrown in debug->Exceptions, gave the same result as running the .exe, the application started, the webcam turned on, and then nothing happened.

 

 

Now for the weird part. I had the application on 2 computers, I had done changes on one of them, and this problem started appearing, but it also started appearing on the computer on which I had made no changes at all (since the last time I ran it). So suddenly, both applications start crashing on the same day, while they had worked before, and without any contact between the two computers.

Thank you for your time,

Ephel

 

Edit:

I tested it out a bit and thought about it, and my logical conclusion was that either a windows update or a expired license was the cause of this, what else could destroy the program on 2 computers at once? I turned out to be right about the license. Setting back the system time to last month fixed the problem.

However, this fix is not a nice one by any stretch of the imagination, and now I'm wondering if it's actually legal. 

So is there any way for you to tell what licence has expired (I'm assuming Alvar because of the calib.xml in the line that threw the error, but can't be sure) and how I could fix this legally? 

 

 

Coordinator
Feb 7, 2011 at 6:04 PM

I'm pretty sure your ALVAR license expired. Which version of ALVAR are you using?

If you're using 1.4.0, it should still be working.

We will have a wrapper for 1.5.0 in the next release.

Ohan

Feb 9, 2011 at 6:51 AM

Hi,

I was using GoblinXNA3.4 and ALVAR 1.3.0, and encountered the same problem. You mentioned about that 1.4.0 should still be working, so I updated to GoblinXNA3.5, along with ALVAR 1.4.0, and still am encountering the same problem.

Coordinator
Feb 9, 2011 at 9:37 AM

Hmmm.... Anyone in our lab and classes use ALVAR 1.4.0 downloaded from VTT website, and it seems to work fine for them.

Anyone else is having expiration problem for 1.4.0?

Ohan