This project is read-only.


May 8, 2011 at 7:16 PM


I was busy installing GoblinXNA, when I came across a hitch. Alvar1.4 requires me to use Visual C++ 2008 to compile the source into alvarwrapper.dll
I lost my image for Visual Studio 2008, but I still have C# 2008 installed. I also have the Visual Studio 2010 image. But alas, Alvar wants me to open it in 2008. If I try to convert it to 2010 I eventually hit an error when building dll. I have slow internet, so it'd take me a week or so to download the image once more, which I don't really want to do.

TL;DR: Can someone upload the dll file, so I can just put it in the unmanaged directory?


May 9, 2011 at 9:37 AM

You'll need visual studio 2008 for all the current releases of goblin XNA anyway. There's no way to run goblin in vs2010 without using the closed beta. If youre not experienced with goblin at all, i'd recommend you to stick with the 2008 version as theres still some small issues with the new version. (shadowmapping for example).

Can't you just download the visual c++ express edition? its a 300mb download or something.

May 9, 2011 at 9:43 AM

I already have Visual C# 2008, just not the other ones. You'll note that I said I have slow internet. Even 300mb will take about a day to download. Sigh, I guess I'll just have to download it then.
I still don't understand why someone can't just upload the dll. 

May 9, 2011 at 1:25 PM

After *finally* downloading it, I get this error when trying to compile :/

1>------ Build started: Project: ALVARWrapper1.4, Configuration: Debug Win32 ------1>Compiling...1>cl : Command line warning D9035 : option 'Wp64' has been deprecated and will be removed in a future release1>MarkerDetectorWrapper.cpp1>c:\users\MYUSERNAME\documents\goblinxna\goblinxnav3.5\wrappers\alvarwrapper1.4\alvarwrapper\markerdetectorwrapper.cpp(36) : fatal error C1083: Cannot open include file: 'MarkerDetector.h': No such file or directory1>Build log was saved at "file://c:\Users\MYUSERNAME\Documents\goblinxna\GoblinXNAv3.5\wrappers\ALVARWrapper1.4\ALVARWrapper\Debug\BuildLog.htm"1>ALVARWrapper1.4 - 1 error(s), 1 warning(s)========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

May 9, 2011 at 1:42 PM

You need to double check the references to alvar in your linker settings. By defeault it still links to the location of odan's system, and he refers to alvar pro. You'll need to relocate them to the place you installed alvar and refer to the include, platform and pro folders of your alvar installation.

May 9, 2011 at 2:21 PM

How do I do this?

May 9, 2011 at 2:25 PM

Right-click on the alvarwrapper-project and select properties. Then select configuration properties, and check everything in C/C++ and Linker. Then you should be allright

May 9, 2011 at 2:40 PM


May 9, 2011 at 2:51 PM

Well I just can't seem to compile Alvarwrapper.dll properly. Can't you just upload it? It would save me a great deal of time trying to get it to work.

May 11, 2011 at 11:10 AM
Edited May 11, 2011 at 11:11 AM

Did you still get the same error?

Even if i would send the wrapper to you, there's still a big chance that you still cant operate anyting with goblin. Did you manage to run any of the alvar samples? It's recommended to just compile the thing yourself, as it's a great learning experience, and an important step in understanding goblin.

Goblin isn't as simple as FlarToolkit for flash for example.