This project is read-only.

EntryPointNotFoundException with 'NewtonWorldFreezeBody' function?

Jul 17, 2009 at 6:29 PM
Edited Jul 17, 2009 at 6:30 PM

Hi. I'm newbie who entered Goblin XNA world recently.

Currently I'm having trouble with running tutorials.

The problem is as above. Debugger constantly complains with that message with most of tutorial projects when I run them.

I've tried to figure out whether tha function was removed from recent release of Goblin XNA or Newton physics engine but no one says so.

Of course Newton.dll file is included in my tutorial project, and no referential warning is observed.

The things singular with me is that I'm trying to use Goblin XNA with XNA 3.1, Newton 2.03 Beta, and Goblin XNA 3.2. The installation guide says me to use Newton 1.53 and XNA 3.0.

Also I'm curious which dll is specific Newton.dll file mentioned in the guide document, as I found out that there were two types of Newton.dll in the release of Newton 2.03 (What's the difference between two dll in dll_double_vs9 folder and dll_vs9?)

Does these difference can cause serious problems such as this?


Jul 17, 2009 at 9:12 PM


If the version of the library changes, the interface can change a lot, and that's the case for Newton library. 

I've tried to convert the support of Newton from 1.53 to 2.03 a few months ago, but there were so many changes including the interfaces, so I didn't have time to finish the conversion. 

NewtonWorldFreezeBody is one of the function that's been changed from 1.53, so unless you use the Newton.dll 1.53, Goblin XNA won't work (until I finish the conversion).

I haven't tried XNA 3.1 yet, but I believe it should work fine, so the only problem should be the Newton library.




Jul 18, 2009 at 2:55 AM

Thanks for your answer!! Finally I understood what's the problem.