This project is read-only.

ALVAR 1.1.83 release

Coordinator
Oct 18, 2009 at 2:49 PM

I just realized that there is a new release for ALVAR, and it uses OpenCV 2.0 instead of 1.0 now. The wrappr I included in the distribution is for ALVAR 1.1.0 which is their initial release, so the wrapper may not compile (I haven't had time to check yet). Also, you should be installing OpenCV 2.0 instead of 1.0 if you're using version 1.1.83 of ALVAR.

I may or may not have time to check the new release until I get back from ISMAR 09, which ends on 10/22, so please be aware that the wrapper may not compile. I will update the wrapper as soon as I get time, and will post information here.

Ohan

Oct 21, 2009 at 9:40 PM

ALVAR 1.2.0 has been released, and apparently the wrapper doesn't compile to me. I'm using OpenCV 2.0, by the way, and even after changing the paths to my ALVAR and OpenCV installations I keep getting a linking error:

LINK : fatal error LNK1181: cannot open input file 'alvar.lib'

Is there anything I can do to fix this?

Jocchan

Oct 23, 2009 at 8:41 PM

alvar.lib has been renamed to alvar120.lib

Project > Properties > Linker > Input

 

these changes:

alvarplatform.lib ---> alvarplatform120.lib

alvar.lib --> alvarplatform120.lib

 

now if i could solve my UNRESOLVED EXTERNAL SYMBOL _cvCreateImage!

anyone? please?

 

Thanks,

 

_C

Oct 25, 2009 at 12:19 PM

Thanks Camb, I still have the same issue as you now.

I tried digging in the ALVAR include files but couldn't find anything useful.

Some help will be appreciated, thanks in advance.

Jocchan

Coordinator
Oct 25, 2009 at 10:21 PM

Hi all,

Sorry for the wait. Now I added a wrapper for ALVAR 1.2.0 in the wrappers directory. Please either re-download GoblinXNAv3.3.zip or get the ALVARWrapper1.2 project from the SVN repository accessible under "Source Code".

I also updated the Installation Guide.pdf for using ALVAR 1.2.0 with Goblin XNA.

When you use the wrapper generated using ALVAR 1.2.0, you also need to copy the alvar120.dll and alvarplatform120.dll under Alvar1.2.0/bin/msvc90, and highgui100.dll under OpenCV/bin to the GoblinXNA/bin directory as noted in the updated Installation Guide. If you're using a wrapper generated using ALVAR 1.1.0, then you won't need these additional dlls. 

Note that we do not have a wrapper for 1.1.83 since it's an intermediate release, so please either get 1.1.0 or 1.2.0 from VTT.

Ohan

Oct 26, 2009 at 12:17 PM

Thanks for helping, downloading now.