Tutorial 8 - Problem with ALVARDllBridge.alvar_add_multi_marker()

May 21, 2010 at 3:58 PM

Hi,

I'm new using Goblin XNA.    I've just install everything required.   Most of the tutorials run in Alvar and Goblin XNA.

My problem is with the tutorial 8.   It fails at the following line:  

ALVARDllBridge.alvar_add_multi_marker(ids.Length, ids, markerConfigName);

The parameters seems to be ok.

I think it's related to the only bug I have running the samples in Alvar:  SampleMultiMarkerBundle

When I run it, it crashs saying "Vector subscript out of range"...  (In the vector librairy of C++).

Do I need to run "SimpleCamCalibMarker"?   They talk about it in the Alvar documentation, but the application IS NOT in the list of samples I have (after generate.bat has compiled the samples).

In advance, thanks!

Sébastien

 

Coordinator
May 21, 2010 at 8:02 PM
Hmm.... that sounds strange. Please make sure that you use the right version of ALVAR (1.3.0) and the wrapper code (ALVARWrapper1.3). The SimpleCamCalibMarker should be as long as I know. If it's missing, please contact VTT. I don't think SampleMultiMarkerBundle works with basic version of ALVAR. I think they only allow it in pro version. Ohan
May 22, 2010 at 2:17 PM

Hi,

Ok... I'm sure I have the right version of Alvar (1.3.0).  

I'm using the ALVARWrapper1.3:  It generate ALVARWrapper1.3.dll (but the Goblin project look for ALVARWrapper.dll!   I have to rename this dll).

I'll try to find out the SimpleCamCalibMarker.  It must be usefull to generate something like a configuration file...  

Since I plan de teach Augmented Reality to a college groupe in computer science in next september, I could be active on this forum in the next months.  

Thank you for your reply!  I appriciate it!  

Sébastien

 

May 26, 2010 at 4:30 AM

Hi Ohanoda,

Well!  I've learned several things since the last time!    Ok, now everything is fine with Alvar (compile and run all), and in Goblin, I can run all the tutorial!   Great!

The only problem is when I try to run AR Dominos...   I can generate the solution.   But it fails when this line is executed (DominoGame.cs):

<font size="2">

tracker.InitTracker(captureDevice.Width, captureDevice.Height,

</font>"calib.xml", 9.0);

It says "DLL NOT FOUND EXCEPTION".  

Although, the AlvarWrapper.dll is in Goblin/bin (it worked with tutorial 8).  The object "tracker" has been declared.   The captureDevice is initialised.   And Calib.xml is valid.

The link to the AlvarWrapper.dll in Goblin/bin is OK in the project.

Any idea?

In advance, thanks!

Sébastien

  

 

May 26, 2010 at 6:58 PM

Ok. Got it.   We have to change the execution path to Goblin/bin instead of ARDominos/bin/release.

Great! :-)