This project is read-only.

cannot open input file 'alvar120.lib'

Jun 2, 2010 at 1:44 PM

Hi there!

I'm installing Globin, following the Installation Guide instructions.

I'm on the step 2 A, compiling the ALVAR 1.2 solution(and I tried with 1.3 too). I checked the paths to the libraries and it's all right.

When I compile I get this error:
Error 1 fatal error LNK1181: cannot open input file 'alvar120.lib' ALVARWrapper1.2 ALVARWrapper1.2

Some help to solve this issue?

Jun 2, 2010 at 10:44 PM

If the path is correct, then it should find the .lib files. Make sure the directory path you indicated actually has the right libraries.


Jun 3, 2010 at 8:01 PM
Edited Jun 3, 2010 at 8:04 PM
Hi ohanoda, thanks to reply. File "alvar120.lib" should be on my hard drive, before compiling? or it's created at the time of compilation? Excuse my ignorance but I'm learning step by step! thanks
Jun 7, 2010 at 2:34 PM
Some help?? Pleaseeee
Jun 7, 2010 at 6:25 PM

in ALVARWrapper1.3.sln i used these "Additional Include Directories" for C/C++:

"C:\Program Files (x86)\Alvar 1.3.0\include\pro";"C:\Program Files (x86)\Alvar 1.3.0\include\platform";"C:\Program Files (x86)\Alvar 1.3.0\include";"C:\Program Files (x86)\OpenCV\cv\include";"C:\Program Files (x86)\OpenCV\cxcore\include

and these "Additional Library Directories" for Linker:

"C:\Program Files (x86)\OpenCV\lib";"C:\Program Files (x86)\Alvar 1.3.0\bin\msvc90"

make sure you specify correct paths!!

try it.

or i can send you the ALVARWrapper.dll if you still can't get it right.

good luck!

Jun 9, 2010 at 3:42 PM
Edited Jun 9, 2010 at 3:44 PM
Hi Alkasai, thanks to reply :) I tried changing the paths in the linker, but now system returns this error: fatal error LNK1104: cannot open file 'C:\Archivos de programa\OpenCV\lib;C:\Archivos de programa\Alvar 1.3.0\bin\msvc90;.obj' I would like to know why this error occurs to resolve similar problems in the future, but You do me a big favor sending me the compiled solution! my email is: THANKS A LOT!