This project is read-only.

SampleCamCalib vs. Vuzix iWear VR920

Oct 30, 2010 at 1:56 AM

Hi everyone, hello Ohan!

Yes, another SampleCamCalib topic (yet again!). This one is about a precise issue, though, not about being unable to compile the program.

I am working on my laptop which has an integrated webcam that I successfully calibrated with sampleCamCalib. However, when I plug in the Vuzix iWear VR920 with the Dynex 1.3 webcam to try and calibrate it, the program starts normally but only displays a black screen instead of the camera output. I'm sure I disactivated my laptop's integrated camera since the Goblin tutorials use the Dynex camera instead. However, the 3d images are very unstable, so I think that calibrating the camera could help.

Any idea anyone?

Oct 30, 2010 at 9:50 PM

Are you using ALVAR 1.4? If so, I had similar problem as well. That's why I included a C# wrapped version of SampleCamCalib.

You can calibrate your camera using CameraCalibration program under /tools directory assuming your have v3.5.


Oct 31, 2010 at 2:33 PM


I'm using Alvar 1.3.0 and GoblinXNA 3.4 right now.

I'll try 3.5.


Oct 31, 2010 at 5:37 PM

Hello, it's me again!

Having installed GoblinXNA 3.5 succesfully, I'm trying to run the CameraCalibration program, but it seems that it cannot find the ALVARWrapper.dll file, which I put in the /dll/unmanaged directory, as stated in the installation guide...

I tried deleting it and adding it manually to the project but it doesn't help. What can I do now?

Oct 31, 2010 at 7:38 PM

"Cannot find ALVARWrapper.dll" doesn't mean it can't find ALVARWrapper.dll, but it can't find other dlls that ALVARWrapper.dll accesses. Did you install OpenCV 1.0 and restarted your machine? Also, do you have all of the necessary dlls mentioned in the installation guide in appropriate folders?


Nov 1, 2010 at 1:22 PM
Edited Nov 1, 2010 at 1:42 PM

Yes, I installed OpenCV 1.0 a few weeks ago, so I rebooted quite a few times since then. And I followed all the steps described in the installation guide. I read that other post, so I'll try what you told ManInTheSuit an try the dependency walker depends.exe.

Thanks Ohan!

Edit: I don't think Glut is installed correctly, though, but everything works but the calibration of the camera, so that's probably why Alvar's SampleCamCalib won't work for me. But still, that doesn't explain why the version our teacher compiled for us doesn't show the Dynex image but works correctly with my laptop's integrated webcam.

Nov 1, 2010 at 3:04 PM

Hello again!

Using Dependency Walker, I found that IEShims.dll is missing (I can't see why you'd need that, though). So I looked in the Internet Explorer directory, and the dll is there. I added the directory to the path and rebooted, but it's still not working. I added the path to ALVARWrapper.dll and rebooted but that didn't help either... I searched the web for answers, but couldn't find anything helpful...

Any idea?

Nov 1, 2010 at 9:24 PM

Hmm... not sure. ALVARWrapper is what I wrote, but the original ALVAR is from VTT. AVLAR should only depend on the dlls listed in the installation guide. 


Nov 2, 2010 at 1:34 PM
Edited Nov 2, 2010 at 4:54 PM

Well, I'm out of solutions. Does anybody have the Calib.xml for for a Dynex 1.3 Webcam? If so please email it to me at



Edit: I still haven't been able to calibrate, but using the right marker really stabilized the 3d images. *&?%$!!!

May 10, 2011 at 8:44 AM

Just in case you still can't run the calibration tool, try running depends.exe over the other dlls than alvarwrapper.dll (ie alvarplatform and the other dependency dlls) that worked for me.

Also, when installing cmake and glut, following the tutorial found you could calibrate using opengl instead.