This project is read-only.

Problems with calib.xml

Feb 3, 2011 at 11:26 PM

hello everyone,

 

well, i follow all steps without any problem..

when i run the project "samplecamcalib" the file that was created is "camera_calibration_highgui_0.xml"..

well, i rename it to calib.xml to run it in tutorial8..

when i run the tutorial8 i get this:

xml is not in the XNA intermediate format. Missing XnaContent root element.

 

my calib.xml:

<?xml version="1.0"?>
<opencv_storage>
<intrinsic_matrix type_id="opencv-matrix">
  <rows>3</rows>
  <cols>3</cols>
  <dt>d</dt>
  <data>
    -1.0462432029028093e+003 0. 336.4961312086086900 0.
    -1.6737823896685791e+003 1.3353201308085099e+003 0. 0. 1.</data></intrinsic_matrix>
<distortion type_id="opencv-matrix">
  <rows>4</rows>
  <cols>1</cols>
  <dt>d</dt>
  <data>
    0.3617856094503178 -1.9303826996318145 -0.2161534791207309
    -5.9419554333624905e-003</data></distortion>
<width>640</width>
<height>480</height>
</opencv_storage>

 

 

 

anyone can help me? best regards

Feb 4, 2011 at 3:11 PM

resolved..

best,

David.

May 11, 2011 at 10:44 PM

Hello,

I'm also getting same message. Would you mind to post how you fixed the problem?

Thank you!

May 12, 2011 at 2:37 PM

include the document in the root folder of your project, instead of in your content folder. (you can also create another folder in your root folder with all the xml documents. I find the last one very convenient as my projects tend to become very complex.)