Camera Calibration

Jul 27, 2011 at 10:56 AM
Edited Jul 27, 2011 at 10:57 AM

Hi, I am new at GoblinXNA, and I just installed all the programs needed, but on Camera Calibration solution I got an error that ALVARWraper.dll file isn't in the unmanaged folder. So I tried ALVARWraper solution and I got to the conclusion that I needed ALVAR 1.1.0 so I installed it, and it worked, but I still get a crash:"Attempting managed execution inside OS Loader lock. Do not attempt to run managed code inside a DllMain or image initialization function since doing so can cause the application to hang." Is ALVAR 1.1 problem or something else?

Jul 27, 2011 at 12:50 PM

Hi,

Try use the Goblin 3.6, he use an ALVAR 1.5, expiration date in 2012.

Jul 27, 2011 at 1:22 PM

I am using 3.6, but cameracalibration in tools in goblin 3.6 is using ALVARWraper.dll, not ALVARWraper150.dll...

Jul 27, 2011 at 1:37 PM

I guess that it has to do something with several threads in a single process, but I'm not very good in threading, so, I don't realy know how to fix it...

Jul 27, 2011 at 1:47 PM

What your email ?

I go to send my ALVARWrapper 1.5 project.

I had the same problem


Jul 27, 2011 at 1:56 PM

mastermana92@gmail.com

thanx, I appreciate it.

Jul 27, 2011 at 1:58 PM

My ALVARWapper is configured with RELEASE and Win32

Jul 27, 2011 at 2:13 PM

I send.

Tell if it worked

Jul 27, 2011 at 3:08 PM

Works! Thank you very much!

Aug 1, 2011 at 2:24 PM

Hi, apparently I'm having the same problem as mastermania experienced. henriquefirewall ,could you please send me your ALVARWrapper project as well.
Email : sabry.moulana@gmail.com

Thanks in advance

Aug 1, 2011 at 3:02 PM

Hi sabryM

I send.

Tell if it worked