marker not working

Nov 9, 2011 at 11:07 AM

suddenly, i messed up something I guess, and some of the markers are not recognized in my game. For example the ground marker works in tutorial8 but when I try to load it in my game, the .markerfound is false. however the toolbar marker works for both. i have no idea how to solve this. any ideas? i created a menu system (using the xna tutorial one) and I think I messed up something with "scene" but not sure. I am stuck. any help is appreciated. 

Nov 12, 2011 at 4:24 AM

appreciate if you can put down your code. I'm still new to this too. perhaps somebody else got an idea or solutions to your problems

Nov 14, 2011 at 8:33 AM

i got the groundmarker working. i needed to put the xml file in debug->content. and it worked. however something utterly strange happens now. in one of my screens I am using the groundmarker and a small marker. then i go to another screen where i use 2 small markers and the program doesn't recognize one of them, instead recognizes the groundmarker for that small marker.  

so in of my screens i have

setUpMarkerNode = new MarkerNode(scene.MarkerTracker, "Marker2Array.xml");           

groundNode = new MarkerNode(scene.MarkerTracker, "GroundArray.xml");

these both work

then i go to another screen where i have

Marker2Node = new MarkerNode(scene.MarkerTracker, "Marker2Array.xml");           

Marker1Node = new MarkerNode(scene.MarkerTracker, "Marker1Array.xml");   

but the program recognizes GroundArray for Marker1Node.    

Nov 15, 2011 at 12:50 AM

i think the problem might be due to the placement of your marker in the scene node. Have you checked that? your initialization seems correct for both

Nov 16, 2011 at 3:23 AM

 i don't know what the actual problem is but, i fixed it when I added Marker1Node to my first screen (even though I don't use it). now the second screen recognizes the marker.