This project is read-only.

Problem with ARTag.cf

Sep 16, 2009 at 11:49 AM
Edited Sep 17, 2009 at 8:06 AM

I'm encountering a problem with Tutorial 8 :

I had problem with ARTagWrapper.dll , but I solved with visual studio C++ 2005.

Now I have another problem with ARTag.cf.............

 

----------------------------------------------Message --------------------------------------------

double artag_camera_fx,artag_camera_fy,artag_camera_cx,artag_camera_cy = 638.05200

2,633.672974,320.000000,240.000000

Problem opening ARTag.cf

Unhandled Exception:GoblinXNA.Device.Vision.Marker.MarkerException: Error loading

marker file sets: ARTag.cf

at GoblinXNA.Device.Vision.Marker.MarkerTracker.SetArrayFile(String sArray Filename)

at GoblinXNA.Device.Vision.Marker.MarkerTracker.InitTracker(Single camera_fx, Single camera_fy, String sArrayFilename)

at GoblinXNA.SceneGraph.Scene.InitMarkerTracker(Single camera_fx, Single camera_fy, String sArrayFilename)

at Tutorial18__Optical_Marker_Tracking.Tutoria18.SetupMarkerTracking( )

at Tutorial18__Optical_Marker_Tracking.Tutiruial8.Initialize( )

at Microsoft.Xna.Framework.Game.Run( )

at Tutorial18__Optical_Marker_Tracking.Program.Main(String[] args)

----------------------------------------------Message --------------------------------------------

What should I do ?? Please help me,,,,,,,       : (                                 

Coordinator
Sep 21, 2009 at 9:02 PM

Hi,

I've never had this problem before. Are you using the original ARTag.cf? If so, it should work fine. If you made changes to ARTagWrapper, that may cause some problems.

Ohan

Sep 29, 2009 at 11:25 AM

I solved this problem.

It was linking error.  :-)

Thank you~

Oct 6, 2009 at 12:57 PM
Edited Oct 6, 2009 at 1:33 PM

I've run into a problem with NewARTag.cf, Newton.dll, ARTagWrapper.dll and freeglut.dll - Visual Studio C# 2008 Express Edition keeps deleting these files whenever I try to compile the tutorial solution file or the goblinxna.dll (not sure on the last one, but the files seemed to be missing right after that when I tried to compile the tutorial sln).
This is annoying and I don't know how to stop the IDE from doing this.
Changing the "Copy to output folder" behavior to "Don't copy" didn't solve the problem.
Any ideas why this might happen? I haven't seen this kind of stuff before.

edit: To make things clear - I could compile everyting successfully (after a few moments of bad headache) by making sure to copy the files over to the bin folder each and every time before building a solution. But I'd still like to know what causes the files to disappear.

Coordinator
Oct 6, 2009 at 8:17 PM

You shouldn't do "Rebuild Solution" or "Clean Solution". It will removes all of its associated files in the bin directory. You should always just do "Build Solution". 

The problem is that I set the tutorials up so that it's copying the files (e.g., Newton.dll) from bin to bin (basically to the same directory), and if you do either Rebuild or Clean, VS will first delete those files, and then try to copy them to bin. Obviously, it will try to copy something that it just deleted. If you don't like this behavior, please copy the resource files such as Newton.dll to some other folder, or change the destination directory of the tutorials to some other directory (e.g., bin/Debug under Tutorial 1 directory). I made everything to stay in the bin directory just to make things look clean. 

Ohan