This project is read-only.

Goblin can't find my ALVARWrapper.dll!

Oct 26, 2009 at 6:55 PM

Hi all,

I'm at my wits end, I'm hoping you might be able to help. I've compiled and run all of the tutorials, but Tutorial 8 - Simple Marker Tracking can't find ALVARWrapper.dll. It's sitting in my Goblin bin directory... I don't know whats wrong!?! I tried downloading the latest version today that supports ALVAR 1.2.0, and I'm still getting the same error.

Can anyone shed any light on why this might be happening?

error message:

Thank you so much in advance,


Oct 26, 2009 at 11:57 PM

I'm getting the exact same thing, and I have no clue whats causing it either.

Oct 27, 2009 at 10:26 AM

Hi, I'm working on windows 7rc, and I had the same issue, ALVARWrapper.dll seemed to compile fine, but I got the same error running tutorial 8.  It seems that some of ALVARWrappers dependencies have been moved out of the system32 folder in win7, and I heard this is also the case for vista.  

I fixed this by using depends.exe to find the missing dll's and putting them into the bin folder.  In my case the missing dlls were IEshims.dll, libguide40.dll and SHLWAPI.dll.

Oct 27, 2009 at 5:59 PM

Hi all,

It will complain that it can't find the wrapper if you have missing DLL dependencies as estiaan pointed out.

Do you have alvar120.dll, alvarplatform120.dll, and highgui100.dll in the bin directory as I mentioned on the discussion board as well as the installation guide?

Also, estiaan, did Tutorial 8 work fine on windows 7?

I know other tutorials (except 13) would work fine on Windows 7, but I'm not sure for Tutorial 8 since there is no guarantee ALVAR (or ARTag) would work on Windows 7. Also, I heard that DirectShowNET is not supported in Windows 7.


Oct 27, 2009 at 8:28 PM
ohanoda wrote:

Do you have alvar120.dll, alvarplatform120.dll, and highgui100.dll in the bin directory as I mentioned on the discussion board as well as the installation guide?

It was not any of the alvar120 dlls, but something from my OpenCV/bin that wasn't being found (highgui100.dll led me to them).

I didn't see anything in the Installation Guide about copying the OpenCV DLLs to GoblinXNA/bin. Maybe its common knowledge to a developer with more MS dev experience, but it tripped me up.

Thanks so much for your help.

Now to troubleshoot why I get no green ball on groundALVAR.pdf...

Thanks again


Oct 27, 2009 at 11:12 PM

Cool. Actually, the copying of highgui100.dll is mentioned in the Installation Guide. Did you get the latest installation guide which is dated 10/25/09?


Oct 28, 2009 at 1:42 AM

Using Depends.exe did the trick for. It was missing a few dlls scattered around the opencv and alvar sdks. 

Thank you estiaan

Oct 28, 2009 at 11:12 AM

Hi Ohan

I also heard that DShowNet is not supported in windows 7, but that video capturing has been simplified using libs included in the system folder.

But I had no need to investigate that further, I followed the instruction guide, and I got Alvar and DShowNet working without any real problems.

Tutorial 8 and all the others work perfectly.  

Thanks for the great documentation!




Oct 28, 2009 at 4:55 PM

Hi estiaan,

It's great to hear that the AR functionalities work on Windows 7!!


Nov 10, 2009 at 6:32 PM

Hi all:

I have some problem with camb416. I have compiled and run on Tutorial 8  and Tutorial 13, and got execption as follows:

DllNotFoundException was unhandled.

Unable to load DLL 'ALVARWarpper.dll'.

And I am 100 percent sure that I already have alvar120.dll, alvarplatform120.dll, and highgui100.dll in the bin directory, and I followed all the steps in the installtion Guide (25/Oct/2009).

  • OS enviorment: Windows Xp with Sp3
  • Visual studio 2008
  • XNA Game Studio 3.1
  • .NET Framework 3.5 SP1
  • ALVARWrapper 1.2
  • OpenCV 1.0
  • Can anyone help me to fix this problem.




Nov 10, 2009 at 7:47 PM
Edited Nov 10, 2009 at 7:48 PM

Hi ssnh,

It seems every machine has different missing files even if the environment is the same.

For my machine and couple other machines I used in the lab worked fine with only alvar120.dll, alvarplatform120.dll, and highgui100.dll, but one of my colleague had problem with it, and required cxcore100.dll as well as cv100.dll in addition. 

The best way to figure out what exactly is missing is to use depends.exe ( as estiaan pointed out earlier.


Nov 10, 2009 at 9:01 PM

Hi Ohan:

Thanks for helping.

I works on my machine now. It requireds cxcore100.dll, cv100.dll and libguide40.dll(Which located in OpenCV\bin). My suggestion in next version of Installtion Guide, it is better let end user ro copy all the dll files from OpenCV\bin to GoblinXNAv3.3\bin.



Jul 9, 2010 at 9:05 PM
Edited Jul 9, 2010 at 9:07 PM

I am going crazy trying to get this tutorial to run.

I ran AlvarWrapper.dll in dependency walker, and moved the following dll files (all of which I had to download, I couldn't find them on my PC) to GoblinXNA/bin directory





This didn't work, and XNA still claims it can't find AlvarWrapper.

Now when running Dependency Walker on AlvarWrapper again it gives me this message, "Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module."

The error seems to be with the msvcr100.dll file.  I just wanted a virtual ball to roll around on a table.


Jul 12, 2010 at 9:59 AM
Hmm... I never needed any of the above dlls. It's been tested on XP, Vista, and 7. The only necessary dlls are those listed in the installation guide. Did you install OpenCV 1.0 which is needed by ALVAR? When you install it, you need to make sure that its path is added to system variables. Also, you need to restart your machine after OpenCV 1.0 install. Ohan
Dec 8, 2010 at 9:24 AM

Hi all,

I've recently realized that for some reason, the path of the OpenCV 1.0's /bin directory is not property added to the environment variables even after you restart your machine for certain machines. This can cause .dll not found problem because it can't access those dlls in the opencv's bin directory. To check whether this is the case, you can open up the command window (, and type cvtest . If it displays "'cvtest' is not recognized ......" message, then the bin path is not properly added.

To fix this problem, you need to manually add your installed opencv bin path (e.g., C://Program Files (x86)/OpenCV/bin/) to your PATH environment variable. Please see regarding how to manually edit the environment variables. 



Mar 23, 2011 at 4:58 PM

Thanks ohannoda, setting the PATH enviroment variable fixed the problem for me.

Note: you need to close the tutorials and open it again after setting the variables.



Aug 19, 2011 at 9:25 PM
Edited Aug 19, 2011 at 9:43 PM

I'm trying to install 3.6. I never had a problem with 3.4. (it still works on the same computer!) However, I have the same issue as Khaosk. cvtest works and for some reason mpr.dll causes this import problem in depends.exe. I'm not sure what to do.


I added ALVARWrapper.dll to the goblin bin directory and it works now. Also, I had to make sure that I compiled the release version of ALVARWrapper because i had moved only the ALVAR dlls that were release, but the compiled ALVARWrapper.dll probably should have been ALVARWrapperd.dll

Nov 17, 2011 at 9:22 AM


I come from another topic. I have gone crazy with ALVARWrapper.dll. I check dependencies with Dependecy Walker and have see errors with IEShims.dll, libguide40.dll and msvcr90.dll. I have put them in dlls/unmanaged folder but the error continues. Them have I copied the dll files to bin/x86 folder and works fine in Windows 7, but I don't know why the files have to be in bin folder.

Thank you!!